<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Dallas Stars Jamie Benn fined $5,000 by League &#8211; NBC 5 Dallas-Fort Worth</title>
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin />
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC 5 Dallas-Fort Worth &raquo; Feed" href="https://www.nbcdfw.com/?rss=y" />
<style class="wp-asset-manager nbc-common-css" type="text/css">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</style><style class="wp-asset-manager nbc-global-css" type="text/css">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</style><link rel='stylesheet' id='all-css-0' href='https://www.nbcdfw.com/_static/??-eJydkMsNwjAQRBsidjb+LQfEgQZowes1wsKfKDaifUBIFJDzvHnSjHytU2h1xDrkuMcSu6wUpj78SK3KkNM3oWfKLEPv0m8jhRyFscxKRWPptih9tKSMEyVV8YEOcp/08qsIzU7P1sCNtULPAcHRbjflFh5dWGRaXGTSgOCdQY3zbmdpfVzb+sx+E4GQLIC2R79YHSEu/D/iXE7w2YEK0OEbriV9Mw==' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcdfw.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcdfw.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<script async src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcdfw.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcdfw.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcdfw.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://www.nbcdfw.com/news/sports/dallas-stars-jamie-benn-fined-5000-by-league/2963233/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcdfw.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcdfw.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><script>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</script><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcdfw.com/2019/09/DFW-1.png?resize=800%2C231&quality=85&strip=all'); }
</style>
<meta property="og:site_name" content="NBC 5 Dallas-Fort Worth" /><meta name="google-site-verification" content="TulxZlVUPoj7DKPRWGCGsen6t4RRfLKo9TwVr3Z-6x0" /><meta property="fb:app_id" content="79562228021" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcdfw" /><meta name="twitter:creator" content="@nbcdfw" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/nbcdfw" /><meta name="description" content="Washington’s Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn’t get penalized during..." /><meta property="og:description" content="Washington’s Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn’t get penalized during their games." /><meta name="twitter:description" content="Washington’s Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn’t get penalized during their games." /><meta property="og:title" content="Dallas Stars Jamie Benn fined $5,000 by League" /><meta name="twitter:title" content="Dallas Stars Jamie Benn fined $5,000 by League" /><meta name="keywords" content="Dallas Stars" /><meta property="og:url" content="https://www.nbcdfw.com/news/sports/dallas-stars-jamie-benn-fined-5000-by-league/2963233/" /><meta name="twitter:url" content="https://www.nbcdfw.com/news/sports/dallas-stars-jamie-benn-fined-5000-by-league/2963233/" /><meta name="sailthru.title" content="Dallas Stars Jamie Benn fined $5,000 by League" /><meta name="sailthru.description" content="Washington’s Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn’t get penalized during..." /><meta name="sailthru.tags" content="Dallas Stars" /><meta name="sailthru.tags" content="Dallas Stars" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-05-09T16:30:13+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?resize=1200%2C675&#038;quality=85&#038;strip=all" /><meta name="twitter:image" content="https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?resize=1200%2C675&#038;quality=85&#038;strip=all" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcdfw.com\/news\/sports\/dallas-stars-jamie-benn-fined-5000-by-league\/2963233\/","headline":"Dallas Stars Jamie Benn fined $5,000 by League","datePublished":"2022-05-09T16:30:13","dateModified":"2022-05-09T16:30:30","description":"Washington&#8217;s Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn&#8217;t get penalized\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Dallas Stars","publisher":{"@type":"Organization","name":"NBC 5 Dallas-Fort Worth","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcdfw.com\/wp-content\/uploads\/2019\/09\/light_amp_kxas.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcdfw.com\/2022\/01\/Logo-Dallas-Stars-NHL.png?resize=1200%2C675&quality=85&strip=all","width":1200},"author":{"@type":"Person","name":"Ronald Blum, Associated Press"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcdfw.com/news/sports/dallas-stars-jamie-benn-fined-5000-by-league/2963233/?amp"><link rel="icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2963233 single-format-standard station-nbc kxas has-featured-image short-hero">
	<div id="leaderboard" class="leaderboard-ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcdfw.com/">
						<img src="https://media.nbcdfw.com/2019/09/DFW_On_Dark@3x-3.png?fit=411%2C120&#038;quality=85&#038;strip=all&#038;w=137&#038;h=40" srcset="https://media.nbcdfw.com/2019/09/DFW_On_Dark@3x-3.png?fit=411%2C120&amp;quality=85&amp;strip=all&amp;w=137&amp;h=40 1x, https://media.nbcdfw.com/2019/09/DFW_On_Dark@3x-3.png?fit=411%2C120&amp;quality=85&amp;strip=all&amp;w=274&amp;h=80 2x, https://media.nbcdfw.com/2019/09/DFW_On_Dark@3x-3.png?fit=411%2C120&amp;quality=85&amp;strip=all&amp;w=411&amp;h=120 3x" alt="NBC 5 Dallas-Fort Worth" height="40" width="137" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcdfw.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Responds" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/nbc-5-responds/">Responds</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Video" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/sports/">Sports</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/entertainment-news/">Entertainment</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcdfw.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcdfw.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Heat Safety" data-lpos="trending-stories-module" href="https://www.nbcdfw.com/news/local/as-temperatures-rise-officials-give-out-heat-safety-tips/2962543/" class="site-header__trending-nav-item">Heat Safety</a>
					<a data-lid="Healthy Counties" data-lpos="trending-stories-module" href="https://www.nbcdfw.com/news/health/collin-denton-counties-top-healthiest-counties-in-texas-list/2959177/" class="site-header__trending-nav-item">Healthy Counties</a>
					<a data-lid="Honoring Moms" data-lpos="trending-stories-module" href="https://www.nbcdfw.com/news/local/honoring-moms-who-give-back-to-their-communities/2962549/" class="site-header__trending-nav-item">Honoring Moms</a>
					<a data-lid="Mavs Outshine Suns" data-lpos="trending-stories-module" href="https://www.nbcdfw.com/news/sports/mavericks-dominate-phoenix-suns-semifinal-series-tied-at-2-2/2962448/" class="site-header__trending-nav-item">Mavs Outshine Suns</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="75261">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2963233" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcdfw.com/tag/dallas-stars/">Dallas Stars</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Dallas Stars Jamie Benn fined $5,000 by League	</h1>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Ronald Blum, Associated Press							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-05-09T21:30:13-05:00">Published 17 mins ago</time>						<span class="meta-dot">&bull;</span>
					<time class="entry-date updated" datetime="2022-05-09T16:30:30-05:00">Updated 17 mins ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F&#038;Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League?_osource=db_npd_nbc_kxas_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League&#038;url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F?_osource=db_npd_nbc_kxas_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F?_osource=db_npd_nbc_kxas_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<figure class="article-featured-media">
	<div class="image-container">
		<img
			srcset="https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=375&amp;h=211&amp;crop=1 375w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=575&amp;h=323&amp;crop=1 575w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=775&amp;h=436&amp;crop=1 775w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=975&amp;h=548&amp;crop=1 975w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=1175&amp;h=661&amp;crop=1 1175w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=1375&amp;h=773&amp;crop=1 1375w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=1575&amp;h=886&amp;crop=1 1575w, https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?fit=1920%2C1080&amp;quality=85&amp;strip=all&amp;w=1775&amp;h=998&amp;crop=1 1775w"
			sizes="(max-width: 768px) 100vw, (max-width: 1200px) calc(100vw - 350px), 850px"
			src="https://media.nbcdfw.com/2022/01/Logo-Dallas-Stars-NHL.png?resize=320%2C180&#038;quality=85&#038;strip=all"
			alt=""
		/>
	</div>
	</figure>
									<div class="article-content rich-text">
									
					
<p>Washington's Evgeny Kuznetsov and Jamie Benn of Dallas were fined $5,000 Sunday for high sticking on a pair of incidents that didn't get penalized during their games.</p>

<p>Kuznetsov's play against Florida's Noel Acciari came in the first period of the Capitals' 6-1 victory in Game 3 Saturday, which put Washington up 2-1 in the Eastern Conference first-round series.</p>

<p>Benn's infraction against Calgary's Andrew Mangiapane was in the middle of the second period of the Stars' 4-2 victory in Game 3. Dallas leads the Western Conference first-round series 2-1.</p>

<p>Both fines were the maximum allowed under the labor agreement. The money goes to the players' emergency assistance fund.</p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<strong><em><strong>Stay informed during the severe weather season with our local news and weather</strong> app. <strong>Download NBC 5 Dallas-Fort Worth</strong> </em>for <a rel="noreferrer noopener" href="https://apps.apple.com/app/id331805052" target="_blank">Apple</a> or <a rel="noreferrer noopener" href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcdfw.android&amp;&amp;" target="_blank">Android</a><strong><em> and pick your alerts. </em></strong></strong></blockquote>
</div>
</div>

									</div>
											<div class="article-copyright">Copyright AP - Associated Press</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcdfw.com/tag/dallas-stars/">Dallas Stars</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F&#038;Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League?_osource=db_npd_nbc_kxas_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League&#038;url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F?_osource=db_npd_nbc_kxas_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Dallas%20Stars%20Jamie%20Benn%20fined%20%245%2C000%20by%20League%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Fsports%2Fdallas-stars-jamie-benn-fined-5000-by-league%2F2963233%2F?_osource=db_npd_nbc_kxas_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				article: 'auto',
				url: ''
			});
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
			});
						_taboola.push({
				flush: true
			});
		};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular">		<div class="most-popular__header">
			<h3 class="widget-title">Trending Stories</h3>
			<div class="sponsored-ad-container">
				<div id="div-gpt-ad-logo_trending" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_trending', format: 'logo', targeting: {"slot":"logo","pos":"logo"} });
			</script>			</div>
		</div>
		<ul class="most-popular__posts-list">
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Woman Shot Twice in Groin Outside Fort Worth Convenience Store"
							href="https://www.nbcdfw.com/news/local/woman-shot-twice-in-groin-outside-fort-worth-convenience-store/2963066/"
						>
							<img
								class="post__image"
								src="https://media.nbcdfw.com/2020/07/fort-worth-police-generic-2.png?resize=100%2C56&#038;quality=85&#038;strip=all"
								alt="Woman Shot Twice in Groin Outside Fort Worth Convenience Store"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="Fort Worth"
									href="https://www.nbcdfw.com/tag/fort-worth/"
								>
									Fort Worth								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Woman Shot Twice in Groin Outside Fort Worth Convenience Store"
								href="https://www.nbcdfw.com/news/local/woman-shot-twice-in-groin-outside-fort-worth-convenience-store/2963066/"
							>
								Woman Shot Twice in Groin Outside Fort Worth Convenience Store							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Car Jerry Jones Hit Was Making Improper Left Turn: Police Report"
							href="https://www.nbcdfw.com/news/local/car-jerry-jones-hit-was-making-improper-left-turn-police-report/2962711/"
						>
							<img
								class="post__image"
								src="https://media.nbcdfw.com/2022/03/GettyImages-1356869110.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Car Jerry Jones Hit Was Making Improper Left Turn: Police Report"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="Dallas"
									href="https://www.nbcdfw.com/tag/dallas/"
								>
									Dallas								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Car Jerry Jones Hit Was Making Improper Left Turn: Police Report"
								href="https://www.nbcdfw.com/news/local/car-jerry-jones-hit-was-making-improper-left-turn-police-report/2962711/"
							>
								Car Jerry Jones Hit Was Making Improper Left Turn: Police Report							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="May 7, 2022, North Texas General Election Results"
							href="https://www.nbcdfw.com/news/politics/lone-star-politics/nearly-300-races-held-on-may-7-election-day-in-north-texas/2960670/"
						>
							<img
								class="post__image"
								src="https://media.nbcdfw.com/2022/03/GettyImages-1058414620.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="May 7, 2022, North Texas General Election Results"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="election results"
									href="https://www.nbcdfw.com/tag/election-results/"
								>
									election results								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="May 7, 2022, North Texas General Election Results"
								href="https://www.nbcdfw.com/news/politics/lone-star-politics/nearly-300-races-held-on-may-7-election-day-in-north-texas/2960670/"
							>
								May 7, 2022, North Texas General Election Results							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Mavericks Fan Allegedly Puts Hands on Chris Paul&#039;s Mother, Escorted From Arena"
							href="https://www.nbcdfw.com/news/sports/mavericks-fan-allegedly-puts-hands-on-chris-pauls-mother-escorted-from-arena/2962508/"
						>
							<img
								class="post__image"
								src="https://media.nbcdfw.com/2022/05/chris-paul-mavericks.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Mavericks Fan Allegedly Puts Hands on Chris Paul&#039;s Mother, Escorted From Arena"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="NBA"
									href="https://www.nbcdfw.com/tag/nba/"
								>
									NBA								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Mavericks Fan Allegedly Puts Hands on Chris Paul&#039;s Mother, Escorted From Arena"
								href="https://www.nbcdfw.com/news/sports/mavericks-fan-allegedly-puts-hands-on-chris-pauls-mother-escorted-from-arena/2962508/"
							>
								Mavericks Fan Allegedly Puts Hands on Chris Paul&#039;s Mother, Escorted From Arena							</a>
						</div>
											</div>
				</li>
							<li class="most-popular__post">
					<div class="post__image__wrap">
												<a
							data-lpos="most-popular"
							data-lid="Woman Steals Ambulance, Leads Garland Police on a Chase"
							href="https://www.nbcdfw.com/news/local/woman-steals-ambulance-leads-garland-police-on-a-chase-sunday/2963137/"
						>
							<img
								class="post__image"
								src="https://media.nbcdfw.com/2019/09/101519-generic-ambulence-picture-1.jpg?quality=85&#038;strip=all&#038;resize=100%2C56"
								alt="Woman Steals Ambulance, Leads Garland Police on a Chase"
								loading="lazy"
							/>
						</a>
											</div>

					<div class="post__content">
													<h4 class="post__category">
								<a
									data-lpos="most-popular"
									data-lid="Garland"
									href="https://www.nbcdfw.com/tag/garland/"
								>
									Garland								</a>
							</h4>
												<div class="post__title">
							<a
								data-lpos="most-popular"
								data-lid="Woman Steals Ambulance, Leads Garland Police on a Chase"
								href="https://www.nbcdfw.com/news/local/woman-steals-ambulance-leads-garland-police-on-a-chase-sunday/2963137/"
							>
								Woman Steals Ambulance, Leads Garland Police on a Chase							</a>
						</div>
											</div>
				</li>
										<li class="most-popular__post taboola__post">
					<div id="taboola-right-rail-thumbnails---fallback"></div>
				</li>
				<script>
					try {
						window._taboola = window._taboola || [];
						_taboola.push({
							listenTo: 'nocontent',
							placement: 'Right Rail Thumbnails - Fallback',
							handle: function() {
								document.querySelector('.most-popular__post:nth-of-type(5)').remove();
							}
						});
						_taboola.push({
							mode: 'thumbnails-a-right-rail',
							container: 'taboola-right-rail-thumbnails---fallback',
							placement: 'Right Rail Thumbnails - Fallback',
							target_type: 'mix',
							flush: true,
						});
					} catch (e) {
						console.error(e);
					}
				</script>
					</ul>
		</section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_214" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_214', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Dallas, TX"></div>
	<a class="weather-module__conditions" href="https://www.nbcdfw.com/weather/">
		<div data-react-component="IframeConditions" data-location="75261"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_157" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_157', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_492" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_492', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-739375320" class="module-civicScience" data-tgtid="dd340b59-5969-2dc4-f1dc-f4e9d7a7369c"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_581" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_581', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_583" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_583', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_347" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_347', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcdfw.com/" class="site-footer__logo">
					<img
						src="https://media.nbcdfw.com/2019/09/DFW_On_Light@3x.png?fit=411%2C120&#038;quality=85&#038;strip=all"
						alt="NBC 5 Dallas-Fort Worth"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2253103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2253103"><a href="https://www.nbcdfw.com/contact-us/">Contact Us</a></li>
<li id="menu-item-2253068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2253068"><a href="https://www.nbcdfw.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2272726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2272726"><a href="/live/">TV Listings</a></li>
<li id="menu-item-2352239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2352239"><a href="https://www.nbcdfw.com/ugc">Submit Photos or Video</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1966005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966005"><a href="https://publicfiles.fcc.gov/tv-profile/KXAS-TV">KXAS Public Inspection File</a></li>
<li id="menu-item-2469463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2469463"><a href="https://www.nbcdfw.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1966006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966006"><a target="_blank" rel="noopener noreferrer" href="http://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_5_Dallas_Fort_Worth/">Privacy Policy</a></li>
<li id="menu-item-2228230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2228230"><a href="http://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_5_Dallas_Fort_Worth/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1966020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966020"><a href="https://www.nbcdfw.com/kxas-employment-information/">KXAS Employment Information</a></li>
<li id="menu-item-1966019" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966019"><a href="https://www.nbcdfw.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1966008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966008"><a href="https://together.nbcuni.com/advertise/?utm_source=nbcdfw&#038;utm_medium=referral&#038;utm_campaign=property_ad_pages">Advertise with us</a></li>
<li id="menu-item-1966018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966018"><a href="https://www.nbcdfw.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2410954" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2410954"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_5_Dallas_Fort_Worth">CA Notice</a></li>
<li id="menu-item-1966007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966007"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">Ad Choices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcdfw.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "sports";
		_sf_async_config.authors  = "Ronald Blum, Associated Press";
		_sf_async_config.title    = "Dallas Stars Jamie Benn fined $5,000 by League";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2963233' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-kxas\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcdfw.com/news/sports/dallas-stars-jamie-benn-fined-5000-by-league/2963233/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcdfw.com/">
					<img
						src="https://media.nbcdfw.com/2019/09/DFW_On_Light@3x.png?fit=411%2C120&#038;quality=85&#038;strip=all"
						alt="NBC 5 Dallas-Fort Worth"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcdfw.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Wake Up to Something Good" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/something-good/">
					Wake Up to Something Good				</a>
							<a data-lid="Health Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/health/">
					Health Connection				</a>
							<a data-lid="Carter In The Classroom" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/local/carter-in-the-classroom/">
					Carter In The Classroom				</a>
							<a data-lid="Texas News" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/texas-news/">
					Texas News				</a>
							<a data-lid="U.S. &amp; World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Weather Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/weather-connection/">
					Weather Connection				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Sports Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports Connection				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="NBC 5 Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/nbc-5-responds/">
					NBC 5 Responds				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/videos/">
					Video				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Texas Today" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/texas-today/">
					Texas Today				</a>
							<a data-lid="Submit Photos or Videos" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/ugc/">
					Submit Photos or Videos				</a>
							<a data-lid="Community" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/about-nbc-5/community/">
					Community				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Submit a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Contests" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="http://products.studiosatdfw.com/">
					Our Apps				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/newsletters/">
					Newsletters				</a>
							<a data-lid="TV Schedule" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/live/">
					TV Schedule				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="http://www.cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us%20"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcdfw.com/_static/??-eJydzEsOwiAUheENWSjlPTCOnbiHy+U2krRgCrVx9+LABej4/Ofjx2PAkhvlxtudVqo8Bxxqg5ZK5rikzxL2tESOtfK5lEYbI+81UgAVQ/BEYAxNbE2Z9ebEfzWXV9nbDZ7MI6CyYJwERCnCpJ34mz0IerZd+6eyUUF042xidFoJO85R2q98Wc/CaOGkcNa9AcHjX2g=' type='text/css' media='all' />
<script src='https://www.nbcdfw.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://www.nbcdfw.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "88fc2ce5eb" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://www.nbcdfw.com/wp-admin/admin-ajax.php?action=rest-nonce";
wp.apiFetch.use( wp.apiFetch.createPreloadingMiddleware( {"\/nbc\/v1\/weather-alerts":{"body":[],"headers":[]}} ) );
</script>
<script src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/common.d27cd2fc7d4f68140717.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.6094cd490c241c388199.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/global.457595877dbca9ad3352.bundle.min.js?ver=1.0.2' id='nbc-global-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/article.f236bc4f1925227c12d9.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.9' id='sharethrough-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.d5c7059c7d75fb8f3d73.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/articleContent.3f5fe9de74890486d99b.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://www.nbcdfw.com/wp-includes/js/wp-embed.min.js?ver=5.5.9' id='wp-embed-js'></script>
<script src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/civicScience.3435258b523b047b5fa7.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script src='https://stats.wp.com/e-202219.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596142',post:'2963233',tz:'-5',srv:'www.nbcdfw.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '165596142', '2963233' ]);
</script>

</body>
</html>
