<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<title>Caught on Camera: Street Stunt Drivers At It Again in Dallas &#8211; NBC 5 Dallas-Fort Worth</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC 5 Dallas-Fort Worth &raquo; Feed" href="https://www.nbcdfw.com/?rss=y" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.nbcdfw.com/_static/??-eJzNksFuwyAQRH+oGBNDDIeq37Is6xgFgwVYlf++JFWqRq0qNb30OrP7ZkHDX1eGKVaKla9hO/lYODgWYKdcWLTIsXxW3LR2TXniv9v72PERw+aoXG3nS+U2JDyz4G2GvPNS90Dd4uOXlGVjt6BCkHHmFKBUj2umG+sCzU2u5NiaSi3snX6lljvs/SFQZt+CfhgB1yxmIX97XJ1paYPt3S0Lqk+RY/AXx24+uCvhFJKF0B0NIU4a8CAmQ0JL1x8eZsYUYVk7aYW2RoOVVpl+HBTox5mYliXFbkKFzqESwowWpZTKUIfzFs//6gcgtwq0yuhxJKEGkiDMRKZXgx3/1KMJkFqB7qvzsjyLY68Psh+MegNtzSqx' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<script src='https://www.nbcdfw.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script id='jquery-core-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script type='text/javascript' src='https://www.nbcdfw.com/_static/??-eJzTLy/QTc7PK0nNK9EvyClNz8wr1k9M0c1JrEwtKtbNS0rWz0IWSEkr0Msq1tEnSRdQh32uraGZgZG5oam5uWEWAPIKKXw='></script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcdfw.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script id='nbc-analytics-js-js-extra'>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</script>
<script type='text/javascript' src='https://www.nbcdfw.com/_static/??/wp-includes/js/dist/i18n.min.js,/wp-content/themes/nbc-station/client/build/js/analytics.76b57476199d65d7b9b9.bundle.min.js?m=1607636138j'></script>
<link rel="https://api.w.org/" href="https://www.nbcdfw.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcdfw.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcdfw.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel="canonical" href="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcdfw.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcdfw.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	@media (max-width: 375px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcdfw.com/2019/09/DFW-1.png?resize=1440%2C415'); }
	}
	@media (min-width: 376px) and (max-width: 768px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcdfw.com/2019/09/DFW-1.png?resize=1440%2C415'); }
	}
	@media (min-width: 769px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcdfw.com/2019/09/DFW-1.png?resize=1440%2C415'); }
	}
</style>
<link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/Roboto-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/Roboto-Regular.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/Roboto-Italic.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/fa-brands-400.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/media/fa-solid-900.woff2" as="font" crossorigin />		<!-- Begin comScore Tag -->
		<script>
		var _comscore = _comscore || [];
		_comscore.push({ c1: "2", c2: "6035083" });
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
				window._taboola = window._taboola || [];
						_taboola.push({'article':'2515866', tracking:'_osource=taboola-recirc'});
						!function (e, f, u) {
					e.async = 1;
					e.src = u;
					f.parentNode.insertBefore(e, f);
				}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/nbcots-network/loader.js');
		</script><script>
			window._newsroom = window._newsroom || [];
					!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/nbcots-kxas/newsroom.js');
		</script>
		<meta property="og:site_name" content="NBC 5 Dallas-Fort Worth" /><meta name="google-site-verification" content="TulxZlVUPoj7DKPRWGCGsen6t4RRfLKo9TwVr3Z-6x0" /><meta property="fb:app_id" content="79562228021" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcdfw" /><meta name="twitter:creator" content="@nbcdfw" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/nbcdfw" /><meta name="description" content="A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway early Wednesday." /><meta property="og:description" content="A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway early Wednesday." /><meta name="twitter:description" content="A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway early Wednesday." /><meta property="og:title" content="Caught on Camera: Street Stunt Drivers At It Again in Dallas" /><meta name="twitter:title" content="Caught on Camera: Street Stunt Drivers At It Again in Dallas" /><meta name="keywords" content="Dallas, Dallas PD, street racing, street stunts" /><meta property="og:url" content="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/" /><meta name="twitter:url" content="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/" /><meta name="sailthru.title" content="Caught on Camera: Street Stunt Drivers At It Again in Dallas" /><meta name="sailthru.description" content="A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway early Wednesday." /><meta name="sailthru.tags" content="Dallas, Dallas PD, street racing, street stunts" /><meta name="sailthru.tags" content="Dallas, Dallas PD, street racing, street stunts" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2020-12-30T06:35:52+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcdfw.com/2020/12/am-v-dallas-street-race_KXASRJK3_2020-12-30-05-40-02.jpg?resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcdfw.com/2020/12/am-v-dallas-street-race_KXASRJK3_2020-12-30-05-40-02.jpg?resize=1200%2C675" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcdfw.com\/news\/local\/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas\/2515866\/","headline":"Caught on Camera: Street Stunt Drivers At It Again in Dallas","datePublished":"2020-12-30T06:35:52","dateModified":"2020-12-30T06:36:01","description":"A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway early Wednesday.","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Dallas, Dallas PD, street racing, street stunts","publisher":{"@type":"Organization","name":"NBC 5 Dallas-Fort Worth","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcdfw.com\/wp-content\/uploads\/2019\/09\/light_amp_kxas.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcdfw.com\/2020\/12\/am-v-dallas-street-race_KXASRJK3_2020-12-30-05-40-02.jpg?resize=1200%2C675","width":1200},"author":{"@type":"Person","name":"Alanna Quillen"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/?amp"><link rel="icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://media.nbcdfw.com/2019/09/cropped-NBC_DFW.png?fit=270%2C270" />
</head>

<body class="post-template-default single single-post postid-2515866 single-format-standard station-nbc kxas has-featured-image short-hero">
	<div id="fb-root"></div>
		<script
			async
			defer
			crossorigin="anonymous"
			src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=79562228021&autoLogAppEvents=1"></script>
		<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcdfw.com/">
						<img
							src="https://media.nbcdfw.com/2019/09/DFW_On_Dark@3x-3.png?fit=411%2C120"
							alt="NBC 5 Dallas-Fort Worth"
							loading="lazy"
						/>
					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcdfw.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/local/">Local</a></li>
<a class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/nbc-5-responds/">Responds</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/sports/">Sports</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/entertainment-news/">Entertainment</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcdfw.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a href="https://www.nbcdfw.com/news/business/money-report/600-stimulus-payments-will-start-going-out-tuesday-night-treasury-secretary-mnuchin-says/2515684/" class="site-header__trending-nav-item">Stimulus Payments</a>
					<a href="https://www.nbcdfw.com/news/coronavirus/what-we-know-about-coronavirus-cases-in-north-texas-around-the-state/2335449/" class="site-header__trending-nav-item">COVID-19 Tracker</a>
					<a href="https://www.nbcdfw.com/about-nbc-5/community/fighting-hunger/" class="site-header__trending-nav-item">Fighting Hunger</a>
					<a href="https://www.nbcdfw.com/entertainment/the-scene/nbc-5-and-nexstar-to-broadcast-annual-new-years-eve-tv-special-lone-star-nye-2021/2511479/" class="site-header__trending-nav-item">#LoneStarNYE</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="75261">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
	</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2515866" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcdfw.com/tag/dallas/">Dallas</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Caught on Camera: Street Stunt Drivers At It Again in Dallas	</h1>
			<h2 class="article-subtitle">
			A large crowd of spectators and drivers performing stunts temporarily shut down the intersection at Empire Central and Stemmons Freeway		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By <a href="https://www.nbcdfw.com?s=Author%3A%20%22Alanna%20Quillen%22">Alanna Quillen</a>							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2020-12-30T12:35:52-06:00">Published 33 mins ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2020-12-30T06:36:01-06:00">Updated 33 mins ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F&#038;Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas?_osource=db_npd_nbc_kxas_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas&#038;url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F?_osource=db_npd_nbc_kxas_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F?_osource=db_npd_nbc_kxas_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
	</div>
</div>
	</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<figure class="article-featured-media">
	<img
		loading="lazy"
		src="https://media.nbcdfw.com/2020/12/am-v-dallas-street-race_KXASRJK3_2020-12-30-05-40-02.jpg?resize=850%2C478"
		alt=""
	/>
			<figcaption>
							<cite>Metro Dallas</cite>
			
					</figcaption>
	</figure>
				<div class="article-content rich-text">

					
<p>It was mayhem on the streets of Dallas early Wednesday.</p>

<p>Video taken about 1 a.m. showed what appeared to be a street stunt event that shut down an intersection in Dallas. Crowds and cars were seen filling the entire intersection at I-35E and Empire Central. Fireworks were flying and people were even hanging out of cars performing stunts, with some vehicles swinging dangerously close to spectators.</p>

<p>Minutes later, Dallas police were seen clearing the scene, but it's unclear if any arrests have been made.</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Local</h3>
	<p class="recirc__subheading">The latest news from around North Texas.</p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a href="https://www.nbcdfw.com/news/coronavirus/what-we-know-about-coronavirus-cases-in-north-texas-around-the-state/2335449/">
							<img class="post__image" src="https://media.nbcdfw.com/2019/09/covid-19-tracker-16x9-1.jpg?resize=850%2C478" alt="" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a class="post__tag" href="https://www.nbcdfw.com/tag/coronavirus/">coronavirus</a>
																			<span class="post__date post__date--has-category">
								Mar 20							</span>
											</div>

											<h3 class="post__title">
							<a class="post__title--link" href="https://www.nbcdfw.com/news/coronavirus/what-we-know-about-coronavirus-cases-in-north-texas-around-the-state/2335449/">
								<span data-ellipsis="true" data-text="COVID-19 Tracker: What We Know About the Virus in DFW and Around Texas" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									COVID-19 Tracker: What We Know About the Virus in DFW and Around Texas								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a href="https://www.nbcdfw.com/news/local/something-good/7-year-old-girl-organizes-toy-drive-to-help-other-kids/2515868/">
							<img class="post__image" src="https://media.nbcdfw.com/2020/12/am-v-sg-evan-brings-xma_KXASRJHB_2020-12-30-07-00-37.jpg?resize=850%2C478" alt="" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a class="post__tag" href="https://www.nbcdfw.com/tag/fort-worth/">Fort Worth</a>
																			<span class="post__date post__date--has-category">
								4 mins ago							</span>
											</div>

											<h3 class="post__title">
							<a class="post__title--link" href="https://www.nbcdfw.com/news/local/something-good/7-year-old-girl-organizes-toy-drive-to-help-other-kids/2515868/">
								<span data-ellipsis="true" data-text="7-Year-Old Girl Organizes Toy Drive to Help Other Kids" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									7-Year-Old Girl Organizes Toy Drive to Help Other Kids								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>Dallas police have not yet responded to NBC 5's requests for more information.</p>

<p>It's another example of the issues Dallas city leaders have been trying to crack down on for years, especially in recent months.</p>

<p>The Dallas Police Department has an established task force to focus on street racing and intersection takeovers by these drivers and their spectators. They say task force officers are typically scheduled on weekend nights when the incidents occur.</p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">CAUGHT ON CAMERA: Mayhem in Dallas overnight. At 1AM, a photojournalist working for <a href="https://twitter.com/NBCDFW?ref_src=twsrc%5Etfw">@NBCDFW</a> captured a street stunt event that shut down the intersection of Empire Central &amp; Stemmons. <a href="https://twitter.com/DallasPD?ref_src=twsrc%5Etfw">@DallasPD</a> cleared the scene but it&#39;s another example of issues <a href="https://twitter.com/CityOfDallas?ref_src=twsrc%5Etfw">@CityOfDallas</a> is cracking down on <a href="https://t.co/wBbuTCNZ8i">pic.twitter.com/wBbuTCNZ8i</a></p>&mdash; Alanna Quillen (@AlannaNBC5) <a href="https://twitter.com/AlannaNBC5/status/1344258968328265729?ref_src=twsrc%5Etfw">December 30, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p>In the past year, DPD has put up police towers and barricades to discourage drivers from re-entering areas where stunts are performed. In Oak Cliff, the city put up traffic calming cones to deter street racing.</p>

<p>But in a recent meeting, Dallas city leaders said while those measures have made improvements in those areas, vehicles are appearing in new locations.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</p>

<p>Earlier in December, Dallas City Council talked about these issues while asking police and Texas lawmakers to help them boost enforcement.</p>

<p>"Our residents are counting on us and in a lot of ways, they feel helpless. And that bothers me," Mayor Eric Johnson said during the virtual meeting. <a href="https://www.nbcdfw.com/news/local/police-and-lawmakers-asked-to-combat-street-racing-and-stunts/2494904/">Click here to read more.</a></p>

<p>So far this year, the city has added a new law that includes the threat of tickets for racing spectators and now, they say tougher state laws are needed to seize vehicles involved in racing and stunt driving.</p>

<p>“I don’t think we solve this problem until we figure out how to make it known, that, in the city of Dallas, if you’re going to partake in this type of behavior you’re going to lose the vehicle. And that gets everybody’s attention. That’s involved in this stuff because that’s what they’re proud of,” said District 1 Councilman Adam McGough.</p>

<p>Dallas police say attention on social media seems to be part of the motivation in these stunts.</p>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcdfw.com/tag/dallas/">Dallas</a><a class="article-tags__tag" href="https://www.nbcdfw.com/tag/dallas-pd/">Dallas PD</a><a class="article-tags__tag" href="https://www.nbcdfw.com/tag/street-racing/">street racing</a><a class="article-tags__tag" href="https://www.nbcdfw.com/tag/street-stunts/">street stunts</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F&#038;Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas?_osource=db_npd_nbc_kxas_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas&#038;url=https%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F?_osource=db_npd_nbc_kxas_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Caught%20on%20Camera%3A%20Street%20Stunt%20Drivers%20At%20It%20Again%20in%20Dallas%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcdfw.com%2Fnews%2Flocal%2Fcaught-on-camera-street-stunt-drivers-at-it-again-in-dallas%2F2515866%2F?_osource=db_npd_nbc_kxas_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
			<a href="#" data-service="comments">
			<i class="fas fa-comment-alt"></i>

			<div class="share-buttons__comment-count">
				<div class="fb-comments-count" data-href="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/">0</div>
			</div>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
		};
	</script>
	<div id="mobile-native-below-article" data-react-component="NativeSponsor" data-title="Native Sponsor" data-include-sponsored="true" data-beforetext="Presented By"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_723" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_723', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Dallas, TX"></div>
	<a class="weather-module__conditions" href="https://www.nbcdfw.com/weather/">
		<div data-react-component="IframeConditions" data-location="75261"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_668" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_668', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_541" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_541', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-739375320" class="module-civicScience"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_968" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_968', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_132" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_132', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_615" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_615', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcdfw.com/" class="site-footer__logo">
					<img
						src="https://media.nbcdfw.com/2019/09/DFW_On_Light@3x.png?fit=411%2C120"
						alt="NBC 5 Dallas-Fort Worth"
					/>
				</a>
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<i class="fab fa-facebook-f"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<i class="fab fa-twitter"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcdfw" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<i class="fab fa-instagram"></i>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2253103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2253103"><a href="https://www.nbcdfw.com/contact-us/">Contact Us</a></li>
<li id="menu-item-2253068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2253068"><a href="https://www.nbcdfw.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2272726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2272726"><a href="/live/">TV Listings</a></li>
<li id="menu-item-2352239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2352239"><a href="https://www.nbcdfw.com/ugc">Submit Photos or Video</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1966005" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966005"><a href="https://publicfiles.fcc.gov/tv-profile/kxas/">KXAS Public Inspection File</a></li>
<li id="menu-item-2469463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2469463"><a href="https://www.nbcdfw.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1966006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966006"><a href="http://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_5_Dallas_Fort_Worth/">Privacy Policy</a></li>
<li id="menu-item-2228230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2228230"><a href="http://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_5_Dallas_Fort_Worth/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1966020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966020"><a href="https://www.nbcdfw.com/kxas-employment-information/">KXAS EMPLOYMENT INFORMATION</a></li>
<li id="menu-item-1966019" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966019"><a href="https://www.nbcdfw.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1966008" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966008"><a href="mailto:limdfwadvertise@nbcuni.com?subject=Advertise%20with%20Us%20HP">Advertise with us</a></li>
<li id="menu-item-1966018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1966018"><a href="https://www.nbcdfw.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2410954" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2410954"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_5_Dallas_Fort_Worth">CA Notice</a></li>
<li id="menu-item-1966007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1966007"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false/">Ad Choices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2020 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type='text/javascript'>
	(function() {
		function CreateEvent(type, data) {
			var event;

			if ('undefined' === typeof data) {
				data = {};
			}

			try {
				event = new CustomEvent(type, { detail: data });
			} catch (err) {
				event = document.createEvent('CustomEvent');
				event.initCustomEvent(type, true, true, data);
			}

			return event;
		}

		var pdk6Url = "https://www.nbcdfw.com/wp-content/themes/nbc-station/static/video/pdk6/player.6.1.3.js";		var pdkScript = pdk6Url;
		if (pdkScript) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.src = pdkScript;
			s.onload = function() {
				window.dispatchEvent(
					CreateEvent('nbc:pdkLoaded')
				);
			};
			document.body.appendChild(s);
		}
	})();
	</script>
	<link rel="stylesheet" href="https://www.nbcdfw.com/wp-content/themes/nbc-station/static/video/pdk6/player_smooth.css?v=102319" type="text/css" />		<script type="text/javascript">
		(function() {
						var _sf_async_config      = window._sf_async_config = (window._sf_async_config || {});
			_sf_async_config.domain   = "nbcdfw.com";
			_sf_async_config.uid      = 15527;
			_sf_async_config.sections = "local";
			_sf_async_config.authors  = "Alanna Quillen";
			_sf_async_config.title    = "Caught on Camera: Street Stunt Drivers At It Again in Dallas";
			
			function loadChartbeat() {
				var e = document.createElement('script');
				var n = document.getElementsByTagName('script')[0];
				e.type = 'text/javascript';
				e.async = true;
				e.src = '//static.chartbeat.com/js/chartbeat.js';
				n.parentNode.insertBefore(e, n);
			}
			loadChartbeat();
		})();
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><i class="fas fa-chevron-left"></i> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcdfw.com/news/local/caught-on-camera-street-stunt-drivers-at-it-again-in-dallas/2515866/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><i class="fas fa-times"></i> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcdfw.com/">
					<img
						src="https://media.nbcdfw.com/2019/09/DFW_On_Light@3x.png?fit=411%2C120"
						alt="NBC 5 Dallas-Fort Worth"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcdfw.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a class="flyout-nav__menu-item child-item" href="/news/health/">
					Health Connection				</a>
							<a class="flyout-nav__menu-item child-item" href="/news/local/something-good/">
					Wake Up to Something Good				</a>
							<a class="flyout-nav__menu-item child-item" href="/news/local/carter-in-the-classroom/">
					Carter In The Classroom				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/nbc-5-responds/">
					NBC 5 Responds				</a>
							<a class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/local/texas-news/">
					Texas News				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a class="flyout-nav__menu-item child-item" href="/weather-connection/">
					Weather Connection				</a>
							<a class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports Connection				</a>
							<a class="flyout-nav__menu-item parent-item" href="/videos/">
					Video				</a>
							<a class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/texas-today/">
					Texas Today				</a>
							<a class="flyout-nav__menu-item child-item" href="http://www.cozitv.com/">
					COZI TV				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/about-nbc-5/community/">
					Community				</a>
							<a class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/ugc/">
					Submit Photos and Video				</a>
							<a class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcdfw.com/newsletters/">
					Newsletters				</a>
							<a class="flyout-nav__menu-item child-item" href="/live/">
					TV Schedule				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<i class="fab fa-twitter"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcdfw" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<i class="fab fa-instagram"></i>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button"
			href="/contact-us%20"
	>
	Contact Us</a>
<script type='text/javascript' src='https://www.nbcdfw.com/wp-content/mu-plugins/jetpack-9.2/_inc/build/photon/photon.min.js?m=1606249811g'></script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.15' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://www.nbcdfw.com/_static/??/wp-includes/js/dist/url.min.js,/wp-includes/js/dist/hooks.min.js?m=1604003341j'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcdfw.com/wp-includes/js/dist/api-fetch.min.js?ver=8773a93ea0d1278a2eaa147fdb6eb96d' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script type='text/javascript' src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/common.024792c5c6d495934db3.chunk.min.js?m=1608235299g'></script>
<script id='nbc-nonamp-js-js-before'>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</script>
<script src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/nonamp.8799ec889e348742965d.bundle.min.js?ver=1.0.2' id='nbc-nonamp-js-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.6767c2059168e0d97fd0.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/global.8fba39375da3978fba27.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/article.eea5332fb569dc35d013.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script async src='https://www.nbcdfw.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.479f15480209020aad49.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.2' id='sharethrough-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/186439-199425704232587.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script type='text/javascript' src='https://www.nbcdfw.com/_static/??/wp-includes/js/underscore.min.js,/wp-content/mu-plugins/search/elasticpress/dist/js/facets-script.min.js,/wp-includes/js/wp-embed.min.js?m=1604003342j'></script>
<script src='https://www.civicscience.com/widget/jspoll/?elt=civsci-739375320&#038;tgtid=dd340b59-5969-2dc4-f1dc-f4e9d7a7369c&#038;ver=1.0.0' id='nbc-civic-science-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202053.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'165596142',post:'2515866',tz:'-6',srv:'www.nbcdfw.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596142', '2515866' ]);
</script>

</body>
</html>
